路由器发行版 OpenWrt 披露了一个远程代码执行漏洞,OpenWrt opkg 包中的一个 bug 会导致包管理器忽略库索引嵌入的 SHA-256 校验和,事实上绕过了下载 .ipk 文件的完整性检查。由于 opkg 包以 root 权限运行,对整个文件系统具有读访问权限,意味着 .ipk 包嵌入的恶意负荷能执行任意代码。开发者已经释出了新版本修复了漏洞。

分享到: